云服务器常见问题

数据分析告诉你:Php最不安全,Nginx比Apache安全

2015-8-14 11:43:36

Google安全研究者Anthony Ferrara分析了那些安装PHP、Python、Nginx、Apache、Wordpress的网站(来自W3Techs),发现70%以上安装着PHP(含有漏洞的版本)的网站都是不安全的。

PHP 最不安全,Nginx比Apache安全

从统计数据中可以看出:在开发语言安全性中,PHP的排名垫底,Python和Perl相对安全;在web服务器中,Nginx比Apache略胜一筹;流行应用中WordPress安全性较强。



针对PHP的统计分析

以下版本的PHP目前是安全的(没有已知漏洞)

5.6.45.5.205.5.125.5.95.4.365.4.165.4.45.3.105.3.35.3.25.1.6

不同发行版Linux维护的PHP版本


PHP5.6


在PHP5.6各版本中,6.7%是安全的,93.3%是不安全的。


PHP5.5

在PHP5.5各版本中,36.6%是安全的,63.4%是不安全的。


PHP5.4

在PHP5.4各版本中,10.6%是安全的,89.6%是不安全的。

总比值超过100.2%是因为W3Techs数据稍有偏差,不影响大局。


PHP5.3

在PHP5.3各版本中,33.9%是安全的,63.1%是不安全的。


PHP5.1

在PHP5.1各版本中,94.8%是安全的,5.2%是不安全的。

ggggg.jpg (70.52 KB, 下载次数: 0)

ggggg.jpg

ggggg.jpg (70.52 KB, 下载次数: 0)

ggggg.jpg

hhhhhhhh.jpg (69.56 KB, 下载次数: 0)

hhhhhhhh.jpg

5.1.jpg (24.99 KB, 下载次数: 0)

5.1.jpg